Pi 3, Admin URL Not Accessible

Just got a Router, Pi 3, and a few pumps. Hooked it all up, worked out of the box for the most part. I was successfully able to get two dispensers to spin based on the default "Black Russian" loaded in the drinks db. However, I can't access the admin page, it's throwing a 404 error, not even asking for a login. Tried by clicking the icon in the top-right, tried directly by appending /admin to the URL. Tried on both an android phone and mac laptop, multiple browsers on each.

What did work was the /admin/login page, and I was able to use the default username/password, but when I was put those in it again threw a 404 error. I tried to shove in the username/password directly in the URL to the admin page but that didn't seem to work either.

I tried to look through the GitHub code and didn't see anything that particularly looked like it was disabling the admin page.

Edit: One thing I noticed was that the "Trending" drink count wouldn't update at all after "making drinks" (I haven't hooked in any liquids, but did get the dispensers working). Unsure if this is relevant.

Any suggestions?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment