Skip to main content
/

Site Navigation

Your Account

Choose Language

If something is wrong with your hardware, see if there's a guide here that can help you out. If you don't see what you need, drop us an email and we'll either write up a guide, or try to point you in the right direction.

10 Questions View all

Dispenser motor runs all the time

Hi,

I have just assembled an Bartendro 7 from one of the Kickstarter kits that I bought second hand (it was still in the box, so not used before).

Everything worked nicely except one of the dispensers would flash briefly blue and then go solid red when I started it up.

I searched for that and it was indicated that it could be an issue with older firmware that made the dispenser enter text mode.

OK, so I downloaded new firmware (dispenser-20150103-04.hex), got an AVR programmer and reprogrammed it. The programming went fine, but immediately after the dispenser motor started and does not stop. Now as soon as I start the thing, this pump starts running and will not stop. Trying reseting in the UI does not work, the software does not detect that dispenser as present.

In addition, now *another* dispenser, which was working fine before, has the brief blue flash then red behavior. Arrgh, now I am down to 5... I don't dare reprogram that one as well, because of what happened to the first one.

My dispensers has v2 written on the back (they don't have the little button). Could there be a compatibility issue with older boards and newer firmware?

I used avrdude with the following command line to do the programming:

avrdude -p atmega168 -c dragon_isp -U flash:w:dispenser-20150103-04.hex

/Jonas

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Great question. This is a symptom of a v2 dispenser being programmed with v3 code. The pump will continually run, and the LEDs will be white. In order to fix it, please program with the correct code.

Dispenser v2 hex

Was this answer helpful?

Score 0

Comments:

Reprogramming with this firmware fixed the always on issue, but unfortunately it did not fix the original issue. The dispensers still flash a couple of times at power on and then they go to a solid color, sometimes blue, sometimes red, and they stay that way when the rest start to animate. The software does not detect that they are there.

by

OK, I solved it. I needed to set a new random ID in the eeprom of the two devices. All is working now!

by

Add a comment

Add your answer

Jonas will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 165